发新话题
打印

[转载]Google工具栏'About'跨站脚本执行漏洞

[转载]Google工具栏'About'跨站脚本执行漏洞

信息来源:特络纳

[受影响系统]:

Google GoogleToolbar

[漏洞描述]:

GoogleToolbar是集成于IE的工具条,方便用户搜索。
GoogleToolbar存在一个输入验证问题,远程攻击者可以利用这个漏洞进行跨站脚本攻击,获得用户敏感信息。

工具栏的'About'段不正确过滤HTML代码,用户可以建立一HTML,当被目标用户装载时,会调用'About'页面,在页面上下问执行任意脚本代码。
<*来源:ViPeR (viper31337@yahoo.co.in

链接:http://marc.theaimsgroup.com/?l= ... 53092727349&w=2
*>



[测试方法]:
警 告

以下程序(方法)可能带有攻击性,仅供安全研究与教学之用。使用者风险自负!

ViPeR (viper31337@yahoo.co.in)提供了如下测试方法:
以下内容为程序代码:

<script>
window.showModalDialog("res://C:\\Program%20Files\\Google\\GoogleToolbar1.dll/ABOUT.HTML",
"<div style=\"background-image:
url(javascript:alert(location.href));\">");
</script>


Rafel Ivgi后来指出 &#39;res:&#39;协议不能从Internet区域调用,因此可防止远程利用此漏洞。

[安全建议]:

厂商补丁:
Google
------
目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
http://toolbar.google.com/
qq310926是我唯一用号,除此之外有其他号码号自称邪八冰血封情,则非本人。

TOP

发新话题